MVC.Controls Version 1.4 with MVC2

Jun 6, 2011 at 5:57 PM

Is it possible to use MVC.Controls 1.4 with MVC2? I get a compilation error

" CS1705: Assembly 'MVC.Controls, Version=1.4.0.0, Culture=neutral, PublicKeyToken=null' uses 'System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a higher version than referenced assembly 'System.Web.Mvc, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'"

 

Thanks,

Barry

Coordinator
Jun 6, 2011 at 6:16 PM

I'm afraid version 1.4.0.0 is compiled using MVC 3 and the System.Web.WebPages assembly.

I'm working on a MVC 2 branch but it's still not public.